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Get started creating web sites

A web site consists of a home page connected to other files by hyperlinks. A web site can be disk-based or server-based.

Set a background for a web page

1. In Page view, right-click the page, click Page Properties on the shortcut menu. 

2. In the Page Properties dialog box, click the Background tab. 

3. Do one of the following: 

Set a color as a background
Do one of the following: 

· Under Colors, in the Background box, select a background color. 

· Define a custom color. 


How?

Under Colors, in the Background box, click More Colors. Then do one of the following: 

· To select a color from the browser-safe palette, click a color. 

· To specify a hexadecimal value, type the value in the Value box. For example, type HEX={FF,33,00}. 

· To select a color on the screen, click Select, and then use the Eyedropper [image: image2]to click the color. For example, to use a color from a picture on an open page, click a color in the picture. 

· To create a color average of the colors in a particular region on the screen, click Select, and then use the Eyedropper  [image: image3]to draw a box on the screen to specify the region. 

· To select a different color or to specify a combination for hue-saturation-luminosity or red-green-blue, click Custom. Under Custom colors, click a blank box. Define a color by entering a combination of values or selecting a color from the color matrix. 

Set a picture as a background
1. Under Formatting, select the Background picture check box. Select Watermark if you 
want your background picture to be a watermark. 

2. Click Browse. 

3. Select the background picture:
· If you know the name of the picture, in File name, type the name of the picture and click Open. 

· If the picture is on a local drive or network, in the Look in box, locate the picture you want. Or, click  one of the buttons in the left of the dialog box to locate the picture. Then click Open. 

· If the picture is on the World Wide Web, click Search the Web [image: image4.png]


. In your Web browser, browse to the picture that you want, and then switch back to Microsoft FrontPage. The location of the page you visited will be displayed in the File name box. Click Open. add a graphic to a web page

You can add a graphics from a variety of sources. Do one or more of the following:

Add a graphic/photo from a file
1. In Page view, position the insertion point where you want to insert a graphic. 

2. On the Insert menu, point to Picture, and then click From File. 

3. Browse to the graphic you want from your local file system or web site, select the file, and click Insert. 

You can specify the type of file you want to view in the Files of type box. 

Note   When you save the page, Microsoft FrontPage prompts you to save the graphic to your web site. Graphics that use 256 or fewer distinct colors are automatically converted to GIF, while all other graphics are converted to JPEG.

Add a graphic/photo from a site on the World Wide Web
1. In Page view, position the insertion point where you want to insert a graphic. 

2. On the Insert menu, point to Picture, and then click From File. 

3. Click Search the Web [image: image5]and navigate to the page that contains the graphic. 

· If you are using Microsoft Internet Explorer 4.x or later: 

1. Right-click on the graphic, and click Copy on the shortcut menu. 

2. Switch back to Microsoft FrontPage. 

3. Right-click again, and select Paste from the shortcut menu to add the graphic directly onto your page. This inserts a reference on your page to the graphic on the Web site. 

Notes  When you save the page, Microsoft FrontPage prompts you to save the graphic to your web site. Graphics that use 256 or fewer distinct colors are automatically converted to GIF, while all other graphics are converted to JPEG. 

· You can choose not to save the graphic to your web site, and in that case, a reference to the graphic on the other web site is created on your page. However, if the graphic is removed from the other web site, you will no longer see the graphic on your own page. 

Add clip art from the Clip Organizer
Microsoft FrontPage includes the Microsoft Clip Organizer. You can preview clip art, graphics, and videos, and then select items to use on your page.

1. In Page view, position the insertion point where you want to insert a graphic. 

2. On the Insert menu, point to Picture, and then click Clip Art. 

3. In the Insert Clip Art task pane, type a word or phrase that describes the clip you want in the Search text box and click Search. 

4. In the Results list, click the clip to insert it. 

To perform another search, click Modify below the Results list. 

Note   You can view the entire Clip Organizer collection of clip art in categories by clicking Clip Organizer at the bottom of the task pane.

Crop a picture 


Hide All

You can crop (crop: To trim vertical or horizontal edges of an object. Pictures are often cropped to focus attention on a particular area.) any picture except an animated GIF (animated GIF: A file that contains a series of Graphics Interchange Format (GIF) images that are displayed in rapid sequence by some Web browsers to produce an animated effect.) picture by using the Crop command. To crop an animated GIF, trim the picture in an animated GIF editing program, and then insert the picture again.

1. Select the picture you want to crop. 

2. On the Picture toolbar (toolbar: A bar with buttons and options that you use to carry out commands. To display a toolbar, click Customize on the Tools menu, and then click the Toolbars tab.), click Crop [image: image7.png]


. 

Note  If the Picture toolbar is not visible, click Toolbars on the View menu, and then click Picture. 

3. Position the cropping tool over a cropping handle and then do one of the following: 

· To crop one side, drag the center handle on that side inward. 

· To crop equally on two sides at once, hold down CTRL as you drag the center handle on either side inward. 

· To crop equally on all four sides at once, hold down CTRL as you drag a corner handle inward. 

4. On the Picture toolbar, click Crop [image: image8.png]


to turn off the Crop command. 

Note  You can undo a crop at anytime before saving the picture.
Insert a movie
To insert a movie into a Microsoft Word document, you must have a movie program such as Media Player — a Microsoft Windows accessory that lets you play audio, video, or animation files — and a sound card installed on your computer.

1. Click where you want to insert a movie. 

2. Do one of the following: 

Insert a movie of your own
On the Insert menu, click Object, and then click the Create from File tab. 

1. Click Browse, and locate the movie you want to insert. 

2. To insert the movie as a linked object (linked object: An object that is created in a source file and inserted into a destination file, while maintaining a connection between the two files. The linked object in the destination file can be updated when the source file is updated.), select the Link to file check box. 

3. To display the movie as an icon, select the Display as icon check box.

Note  To play a movie, double-click its icon.

Add a movie to a Web page
On the Web Tools toolbar (toolbar: A bar with buttons and options that you use to carry out commands. To display a toolbar, press ALT and then SHIFT+F10.), click Movie [image: image9.png]


. 

4. In the Movie box, type the path or Web address (address: The path to an object, document, file, page, or other destination. An address can be a URL (Web address) or a UNC path (network address), and can include a specific location within a file, such as a Word bookmark or an Excel cell range.) of the movie file you want, or click Browse to locate the file. 

5. In the Alternate image box, enter the path or Web address of the graphics file that you want to designate as a substitute when the user's browser doesn't support movies or when the user turns off the display of movies. 

6. In the Alternate text box, enter the alternate text (alternative text: Used by Web browsers to display text during image downloads for users who have graphics turned off and for users who rely on screen-reading software to convert graphics on the screen to spoken words.) that you want to appear in place of the movie or alternate image. 

7. In the Start list, do one of the following: 

· Click Open if you want to play the movie when the user downloads the Web page. 

· Click Mouse-over if you want to play the movie when the user moves the mouse pointer over it. 

· Click Both if you want to play the movie in either scenario. 

8. In the Loop box, enter the number of times you want the movie to repeat. 

Note  To review the movie while you are authoring the Web page, right-click the image representing the movie, and then click Play.

Insert a movie from Clip Organizer
On the Insert menu, point to Picture, and then click Clip Art. 

At the bottom of the Insert Clip Art task pane (task pane: A window within an Office application that provides commonly used commands. Its location and small size allow you to use these commands while still working on your files.), click Organize Clips. 

If you're running Clip Organizer for the first time, click Now to let Clip Organizer import your media clips. If you need assistance importing or organizing files, click Clip Organizer Help on the Help menu in Clip Organizer. 

Note To play a movie, double-click its icon.

Create a hyperlink

In Page view, do one of the following: 
Create a hyperlink to a page or file
1. Select either text or a picture. 
If you do not select text or a picture, the destination URL is displayed as the hyperlink text. 

2. Click Insert Hyperlink  [image: image10.png]


. 

3. Under Link to, click Existing File or Web Page. 

4. Select the page or file you want. 

Create a hyperlink to a new page
1. Select either text or a picture. 
If you do not select text or a picture, the destination URL is displayed as the hyperlink text. 

2. Click Insert Hyperlink [image: image11.png]



3. Under Link to, click Create New Document. 

4. Type the name of the new document. If you want to change the path of the new document, click Change. 

5. Under When to edit, specify whether you want to edit the new document now or later. 

Create a hyperlink to a page or file on the World Wide Web
· Select either text or a picture. 
If you do not select text or a picture, the destination URL is displayed as the hyperlink text. 
· Click Insert Hyperlink [image: image12.png]


. 

· Under Link to, make sure that Existing File or Web Page is selected. 

· Click World Wide Web[image: image13.png]


. 

· In your Web browser, browse to the page that you want to link to, and then press ALT+TAB to switch back to Microsoft FrontPage. The location of the page you visited is displayed in the Address box. 

About tables

A table is made up of rows and columns of cells into which you can insert text and graphics.

There are different ways you can use tables, and you can customize your tables in a variety of ways to make them more attractive and easy to read: 

[image: image26.png]



Present information in a tabular format

Use a table to present information in a grid-like format, such as timetables, product information, rates, and so on.
[image: image27.png]



Lay out text and graphics on a page

When you lay out text and graphics on a page, you can use a table to arrange them. Tables are supported by virtually all Web browsers and are an easy way to lay out your pages.

[image: image28.png]


[image: image16]
Work with rows and columns

You can create more cells in your table by splitting one cell into two or more cells. You can also merge adjacent cells into one cell.

[image: image29.png]e



[image: image18]
Once you have all the rows and columns you need in your table, you can set the row heights and column widths the way you want them. 


[image: image19]You can define the row heights and column widths to be a percentage of the overall table size, a specific size in pixels (pixel: A single unit of measurement that your computer's display hardware uses to paint images on your screen. These units, which often appear as tiny dots, compose the pictures displayed by your screen.), or set all rows and columns to be spaced uniformly. 



Control text and table layout

[image: image30.png]


You can control how your table appears on the page by setting the table alignment — tables can be aligned to the left, right, or center of the page. The table in this picture is centered.[image: image21]You can also control the height and width of the table. For example, you can set the width of the table to 80 percent of the overall page width (or frame width, if the table is in a frame). If a site visitor resizes the browser window, the page size and table change accordingly. On pages that include a table and text, you can also specify whether you want text to flow around the sides of the table.

By specifying the way text appears inside each cell, you can control how much space there is between the border and text of a cell, and you can set the horizontal and vertical alignment of text. In addition, table text can be formatted like any other text — you can change the font style, size, color, and other attributes.

[image: image31.png]


Set border specifications
You can customize the way borders look in your tables. Set the border color for the whole table, or set a different border color for individual cells. You can choose one color for the border, or, if you prefer a three-dimensional look, you can choose two colors — a light color and a dark color. You can also change the thickness of the outer border.

Choose backgrounds
[image: image32.png]i



You can choose background colors and pictures for your tables. Background colors can be used to shade specific columns or rows to add emphasis. You can use background pictures to add visual appeal to your tables.

You can set background colors and pictures for certain cells, or you can set them for the whole table.

Create captions and headers
[image: image33.wmf]You can label or title your tables by adding a table caption. A table caption is placed above or below the table. You can also format the caption text.

To emphasize certain cells in your table, you can specify them as table headers. For example, in the table below, the first row and first column contain labels. They are formatted as table headers so that they stand out from the rest of the table. By default, a table header is formatted as bold text. However, you can modify the table header style and define additional properties for your table headers, such as shading.

Set the background in a table or cell

You can specify a background color or picture for a table or its individual cells.

In Page view, do one or more of the following:

Set the background color for a table
1. Right-click the table, and then click Table Properties on the shortcut menu. 

2. Under Background, in the Color list, select a color for the table background. 


Set the background color for a cell

1. Position the insertion point in the cell, right-click, and then click Cell Properties on the shortcut menu. 

2. Under Background, in the Color list, select a color for the cell background. 

Show a background picture in a table
1. Right-click the table, and then click Table Properties on the shortcut menu. 

2. Under Background, select the Use background picture check box, and then click Browse. 

3. Select the background picture: 

· If you know the name of the picture   Type the name in File name, and click Open. 

· If the picture is on a local drive or network In the Look in box, locate the picture you want. Or, click one of the buttons in the left of the dialog box to locate the picture. Then click Open. 

· If the picture is on the World Wide Web   Click World Wide Web [image: image23]. In your Web browser, browse to the picture that you want, and then switch back to Microsoft FrontPage. The location of the page you visited will be displayed in the File name box. Click Open. 

Notes
· If you set a background color for the table, it will only be visible if the background picture has a transparent color. 

· The background image will be tiled (repeated) unless you are using a cascading style sheet to make it behave otherwise. 



Show a background picture in a cell

1. Position the insertion point in the cell, right-click, and then click Cell Properties on the shortcut menu. 

2. Under Background, click the Use Background picture check box, and then click Browse. 

3. Select the background picture: 

· If you know the name of the picture   Type the name of the picture in File name, and click Open. 

· If the picture is on a local drive or network   In the Look in box, locate the picture you want. Or, click one of the buttons in the left of the dialog box to locate the picture. Then click Open. 

· If the picture is on the World Wide Web   Click World Wide Web [image: image24]. In your Web browser, browse to the picture that you want, and then switch back to Microsoft FrontPage. The location of the page you visited will be displayed in the File name box. Click Open. 

Notes
· If you set a background color for the table, it will only be visible if the background picture has a transparent color. 

· The background image will be tiled (repeated) unless you are using a cascading style sheet to make it behave otherwise. 

*** This information was taken from the Microsoft FrontPage Help files.
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